www.elektronik.si Seznam forumov www.elektronik.si
Forum o elektrotehniki in računalništvu
 
 PomočPomoč  IščiIšči  Seznam članovSeznam članov  SkupineSkupine  StatisticsStatistika  AlbumAlbum  DatotekeFilemanager DokumentacijaDocDB LinksPovezave   Registriraj seRegistriraj se 
  PravilaPravila  LinksBolha  PriponkePriponke  KoledarKoledar  ZapiskiZapiski Tvoj profilTvoj profil Prijava za pregled zasebnih sporočilPrijava za pregled zasebnih sporočil PrijavaPrijava 

EggBot z Arduino kontrolerjem
Pojdi na stran Prejšnja  1, 2, 3, 4, 5, 6, 7
 
Objavi novo temo   Odgovori na to temo   Printer-friendly version    www.elektronik.si Seznam forumov -> Oprema, stroji in orodja
Poglej prejšnjo temo :: Poglej naslednjo temo  
Avtor Sporočilo
joze
Član
Član



Pridružen-a: Pet 26 Jan 2007 10:27
Prispevkov: 158
Aktiv.: 0.98

PrispevekObjavljeno: Pet Nov 22, 2019 9:46 am    Naslov sporočila:   Odgovori s citatom

LP!

Našel sem tole https://forum.arduino.cc/index.php?topic=375719.0
in sem zamenjal "void inline" z "inline void", in sedaj prevede brez napak.
Kje je fora nevem.

Hvala za trud in pomoč.
Nazaj na vrh
Odsoten Poglej uporabnikov profil Pošlji zasebno sporočilo
Jaka57
Moderator
Moderator



Pridružen-a: Ned 12 Dec 2004 21:47
Prispevkov: 5243
Aktiv.: 30.22
Kraj: Grosuplje

PrispevekObjavljeno: Pet Nov 22, 2019 11:18 am    Naslov sporočila:   Odgovori s citatom

Ne vem kaj si kvačkal z mapami, jaz sem enostavno porinil
kompletno odzipano mapo, v mapo kjer imam ostale sketche in prevedel.
Kakorkoli, važno, da si rešil.

_________________
Lp, Jaka
Nazaj na vrh
Skrit Poglej uporabnikov profil Pošlji zasebno sporočilo
s56vha
Član
Član



Pridružen-a: Pet 24 Mar 2006 14:33
Prispevkov: 182
Aktiv.: 1.07
Kraj: Kamnik, Preserje pri Radomljah

PrispevekObjavljeno: Sre Mar 18, 2020 7:00 pm    Naslov sporočila:   Odgovori s citatom

Zdravo

Je kdo poskusil z arduino pro mini in driverji A4988?

Naložil sem več variant z githuba, pa brez uspeha. Inkscape 0.92.4 mi ne prepozna naprave. Extension imam tale.

Imam kond na adruinu med RST in GND, odstranim med nalaganje FW.

Kakšna ideja?
Nazaj na vrh
Odsoten Poglej uporabnikov profil Pošlji zasebno sporočilo
Jaka57
Moderator
Moderator



Pridružen-a: Ned 12 Dec 2004 21:47
Prispevkov: 5243
Aktiv.: 30.22
Kraj: Grosuplje

PrispevekObjavljeno: Sre Mar 18, 2020 7:26 pm    Naslov sporočila:   Odgovori s citatom

Ali se vsakič, ko se hoče povezat Inkscape, Arduino resetira?
_________________
Lp, Jaka
Nazaj na vrh
Skrit Poglej uporabnikov profil Pošlji zasebno sporočilo
s56vha
Član
Član



Pridružen-a: Pet 24 Mar 2006 14:33
Prispevkov: 182
Aktiv.: 1.07
Kraj: Kamnik, Preserje pri Radomljah

PrispevekObjavljeno: Sre Mar 18, 2020 9:17 pm    Naslov sporočila:   Odgovori s citatom

Imam občutek, da se sploh nič ne zgodi. Dobim samo "Failed to connect to EggBot. Sad". Nalaganje skript iz IDE dela BP.
Nazaj na vrh
Odsoten Poglej uporabnikov profil Pošlji zasebno sporočilo
Jaka57
Moderator
Moderator



Pridružen-a: Ned 12 Dec 2004 21:47
Prispevkov: 5243
Aktiv.: 30.22
Kraj: Grosuplje

PrispevekObjavljeno: Sre Mar 18, 2020 11:37 pm    Naslov sporočila:   Odgovori s citatom

Probaj samo s pini TX, RX (brez DTR).
_________________
Lp, Jaka
Nazaj na vrh
Skrit Poglej uporabnikov profil Pošlji zasebno sporočilo
s56vha
Član
Član



Pridružen-a: Pet 24 Mar 2006 14:33
Prispevkov: 182
Aktiv.: 1.07
Kraj: Kamnik, Preserje pri Radomljah

PrispevekObjavljeno: Čet Mar 19, 2020 7:25 pm    Naslov sporočila:   Odgovori s citatom

Sploh ne vem več kaj nisem probal.

Skratka, še enkrat sestavil na protobordu, preveril delovanje, delajo vsi driverji, steperji in servo - na posamezni skripti.

Ko naložim EggDuino, serverji utihnejo - kar je ok. Le Inkscape ga ne prepozna. Dal 10uF med RST in GND, odstranil DTR, nastavljal voltažo na driverjih (0.3V).

Extension EggBot se nahaja v mapi C:\Program Files\Inkscape\share\extensions. Popravil sem ebb_serial.py, kjer sem nastavil COM port: "ebb_port = "COM3"" in VID:PID "if port[2].startswith("USB VID:PID=10C4:EA60"):"

sos1
Nazaj na vrh
Odsoten Poglej uporabnikov profil Pošlji zasebno sporočilo
s56vha
Član
Član



Pridružen-a: Pet 24 Mar 2006 14:33
Prispevkov: 182
Aktiv.: 1.07
Kraj: Kamnik, Preserje pri Radomljah

PrispevekObjavljeno: Pon Mar 23, 2020 5:00 pm    Naslov sporočila:   Odgovori s citatom

Nobody ? sos1
Nazaj na vrh
Odsoten Poglej uporabnikov profil Pošlji zasebno sporočilo
solomojster
Član
Član



Pridružen-a: Tor 18 Maj 2010 12:26
Prispevkov: 804
Aktiv.: 6.69
Kraj: NOVA GORICA

PrispevekObjavljeno: Tor Mar 24, 2020 5:42 pm    Naslov sporočila:   Odgovori s citatom

Preberi na peti strani te teme. Tudi mene je hecalo...
Nazaj na vrh
Odsoten Poglej uporabnikov profil Pošlji zasebno sporočilo
s56vha
Član
Član



Pridružen-a: Pet 24 Mar 2006 14:33
Prispevkov: 182
Aktiv.: 1.07
Kraj: Kamnik, Preserje pri Radomljah

PrispevekObjavljeno: Sre Mar 25, 2020 5:23 pm    Naslov sporočila:   Odgovori s citatom

Vse sem že prebral, 3x tako da ne vem na kaj točno ciljaš.

Naložil 5 različnih egg-sphere-bot varjant. Vedno isto - Inkscape mi ne prepozna zadeve. Trenutno imam sicer različno konfiguracijo MS1-2-3, ampak verjamem, da to ne vpliva. imam 10uF na RST in GND arduina.
Nazaj na vrh
Odsoten Poglej uporabnikov profil Pošlji zasebno sporočilo
solomojster
Član
Član



Pridružen-a: Tor 18 Maj 2010 12:26
Prispevkov: 804
Aktiv.: 6.69
Kraj: NOVA GORICA

PrispevekObjavljeno: Sre Mar 25, 2020 8:06 pm    Naslov sporočila:   Odgovori s citatom

Sam sem uporabil nanota ,povezava prek usb kabla in napajanje drajverjev ločeno....
Nazaj na vrh
Odsoten Poglej uporabnikov profil Pošlji zasebno sporočilo
s56vha
Član
Član



Pridružen-a: Pet 24 Mar 2006 14:33
Prispevkov: 182
Aktiv.: 1.07
Kraj: Kamnik, Preserje pri Radomljah

PrispevekObjavljeno: Sre Mar 25, 2020 8:08 pm    Naslov sporočila:   Odgovori s citatom

Razen to, da nimam nanota, ampak pro mini, sem vse naredil kot piše - v več varjantah. Bom poskusil še starejšo verzijo Inkscape, če je v tem hakeljc.
Nazaj na vrh
Odsoten Poglej uporabnikov profil Pošlji zasebno sporočilo
solomojster
Član
Član



Pridružen-a: Tor 18 Maj 2010 12:26
Prispevkov: 804
Aktiv.: 6.69
Kraj: NOVA GORICA

PrispevekObjavljeno: Sre Mar 25, 2020 8:19 pm    Naslov sporočila:   Odgovori s citatom

Sam sem povezal kabel usb, priklopil napajanje drajverjev in nazadnje pognal inscape.


IMG_20200325_191103.jpg
 Opis:
 Velikost datoteke:  1.11 MB
 Pogledana:  2 krat

IMG_20200325_191103.jpg


Nazaj na vrh
Odsoten Poglej uporabnikov profil Pošlji zasebno sporočilo
s56vha
Član
Član



Pridružen-a: Pet 24 Mar 2006 14:33
Prispevkov: 182
Aktiv.: 1.07
Kraj: Kamnik, Preserje pri Radomljah

PrispevekObjavljeno: Sre Mar 25, 2020 10:26 pm    Naslov sporočila:   Odgovori s citatom

No pa sem ga... Brez spremembe HW in FW na arduinu. Inštaliral Inkscape 0.91, extention Eggbot 250a, popravil PID in VID in to je to. Ne bom sedaj ugotavljal ali je bila težava samo v Inkscape-u ali v extentionu. Skratka, ta konfiguracije trenutno deluje na Win 7 Very Happy
Nazaj na vrh
Odsoten Poglej uporabnikov profil Pošlji zasebno sporočilo
Pokaži sporočila:   
Objavi novo temo   Odgovori na to temo   Printer-friendly version    www.elektronik.si Seznam forumov -> Oprema, stroji in orodja Časovni pas GMT + 2 uri, srednjeevropski - poletni čas
Pojdi na stran Prejšnja  1, 2, 3, 4, 5, 6, 7
Stran 7 od 7

 
Pojdi na:  
Ne, ne moreš dodajati novih tem v tem forumu
Ne, ne moreš odgovarjati na teme v tem forumu
Ne, ne moreš urejati svojih prispevkov v tem forumu
Ne, ne moreš brisati svojih prispevkov v tem forumu
Ne ne moreš glasovati v anketi v tem forumu
Ne, ne moreš pripeti datotek v tem forumu
Ne, ne moreš povleči datotek v tem forumu

Uptime: 38 dni


Powered by phpBB © 2001, 2005 phpBB Group