www.elektronik.si Seznam forumov www.elektronik.si
Forum o elektrotehniki in računalništvu
 
 PomočPomoč  IščiIšči  Seznam članovSeznam članov  SkupineSkupine  StatisticsStatistika  AlbumAlbum  DatotekeFilemanager DokumentacijaDocDB LinksPovezave   Registriraj seRegistriraj se 
  PravilaPravila  LinksBolha  PriponkePriponke  KoledarKoledar  ZapiskiZapiski Tvoj profilTvoj profil Prijava za pregled zasebnih sporočilPrijava za pregled zasebnih sporočil PrijavaPrijava 

Pametni trenažer za kolo, nedelujoč stepper motor

 
Objavi novo temo   Odgovori na to temo   Printer-friendly version    www.elektronik.si Seznam forumov -> Elektronika
Poglej prejšnjo temo :: Poglej naslednjo temo  
Avtor Sporočilo
ogblaz
Član
Član



Pridružen-a: Pet 04 Mar 2016 12:08
Prispevkov: 66
Aktiv.: 1.11
Kraj: Domžale

PrispevekObjavljeno: Ned Jan 10, 2021 6:42 pm    Naslov sporočila:  Pametni trenažer za kolo, nedelujoč stepper motor Odgovori s citatom

Zdravo!

Imam težavo s pametnim trenažerjem za kolo.
Gre za tako imenovan pametni trenažer, katerega povežeš na računalnik/tablco/telefon ta pa ti potem glede na klanec samodejno povečuje/zmanšuje težavnost na kolesu preko aplikacije.
To dela stepper motor kateri približuje ali pa oddaljuje magnete proti vztrajniku.
Tako naj bi se zagnal ko priklopiš.
https://www.youtube.com/watch?v=m7F8Z3Hiei4&ab_channel=MikeVybiral

Moj pa, ko ga priklopiš zapelje magnete čisto naprej in tako ostane. Če priklopiš, ko je motor v tem položaju pa motor le trzne in je zgodba zaključena.
Za položaj skrbi octointeruppter, katerega sem meril in dela normalno. Na mehanizmu je palica katera ta octoineruppter prekine, ko ga prižgeš bi moral motor naprej, ko vidi da palice ni več tam bi morala elektronika obrnit smer in ko bi bil spet prekrit bi mora biti to to.
Kater element bi me lahko hecal, je zadeva sploh popravljiva? Bil bi vesel če bi popravil, ker na suho gonit ni zanimivo Smile
http://hopsasa/f/1A/W3/1NL1HsEd/20210110170204.jpg


Hvala!, Lp



20210110_170144.jpg
 Opis:
 Velikost datoteke:  4.2 MB
 Pogledana:  21 krat

20210110_170144.jpg



20210110_170155.jpg
 Opis:
 Velikost datoteke:  4.04 MB
 Pogledana:  4 krat

20210110_170155.jpg


Nazaj na vrh
Odsoten Poglej uporabnikov profil Pošlji zasebno sporočilo
eddie
Član
Član



Pridružen-a: Sre 10 Dec 2003 21:02
Prispevkov: 624
Aktiv.: 3.41
Kraj: Severna primorska

PrispevekObjavljeno: Pon Jan 11, 2021 9:25 am    Naslov sporočila:   Odgovori s citatom

Če prav razumem se torej motor vrti samo naprej? Kako/kdaj se vrne v začetno pozicijo? Ali to narediš sam ročno?
Da se motor vrti v eno ali drugo smer skrbi pravilno zaporedje "pulzov" na 4ih motornih priključkih. Za to zaporedje lahko skrbi namensko vezje, ki sprejema dva vhodna signala, ki diktirata kdaj naj se motor premika(pulz za vsak korak) in drugi signal za smer v katero naj se vrti. Če takemu vezju odvzamemo signal za smer se bo motor vrtel vedno v isto smer. Tole mi malo izgleda podobno.
Nazaj na vrh
Odsoten Poglej uporabnikov profil Pošlji zasebno sporočilo
malci
Član
Član



Pridružen-a: Sob 15 Sep 2007 21:05
Prispevkov: 645
Aktiv.: 3.97
Kraj: Polhov Gradec

PrispevekObjavljeno: Pon Jan 11, 2021 10:01 am    Naslov sporočila:   Odgovori s citatom

Citiram:
Za to zaporedje lahko skrbi namensko vezje,


Ampak na tej plošči jaz takega vezja ne vidim. Bi rekel, da je prišlo do okvare senzorja pozicije magneta, mogoče ožičenje le tega (kak slab stik). Kako si preveril senzor (in kje)?
Je samo ta (od tega senzorja) vhod na plato? Mogoče še kake tipke?

lp

_________________
Elektronika za hobi
Nazaj na vrh
Odsoten Poglej uporabnikov profil Pošlji zasebno sporočilo
bbrane
Član
Član



Pridružen-a: Čet 14 Jun 2007 15:02
Prispevkov: 538
Aktiv.: 3.25
Kraj: Cerkno

PrispevekObjavljeno: Pon Jan 11, 2021 11:16 am    Naslov sporočila:   Odgovori s citatom

Ne vem sicer kako povezavo imajo tisti smd elektroliti z motorčkonm. Jaz bi jih vseeno prveril. Zadnje čase imam zelo slabe izkušnje prav s takimi SMD elektroliti. Zadnje čase sem popravljal vsaj 5 kosov servoregulator MISUBISHI in vzrok za nestart pri štirih sta bila dva dva taka elkota 10mikro, 25V pri enem pa en izolacijski ojačevalnik občutljiv na temperaturo. V moji primerih se je kondijem zelo povečala vrednost ESR ( tudi preko 50 ). Kapacitivnost niti ni preveč odstopala. Za probo lahko elkote pogreješ s spajkalom in se trenutno zadeva malo popravi. Tako sem jih jaz odkril brez večjega poglabljanja v zadevo.

LP Brane

_________________
En poizkus je vreden več kot tisoč strokovnih mnenj
Nazaj na vrh
Odsoten Poglej uporabnikov profil Pošlji zasebno sporočilo
ogblaz
Član
Član



Pridružen-a: Pet 04 Mar 2016 12:08
Prispevkov: 66
Aktiv.: 1.11
Kraj: Domžale

PrispevekObjavljeno: Pon Jan 11, 2021 11:20 am    Naslov sporočila:   Odgovori s citatom

Prvo hvala obema za odgovor!
Senzor sem preveril tako, da sem imel plato prižgano in sem iz kartonom prekril senzor.
Meril sem iz piskačem in je piskalo na označenih 2 padih.
Če iz telefonom prek kamere pogledaš se vidi da IR led sveti. Potem sem gledal kam pelje trace iz senzorja in pelje do tega malega čipa. Naprej pa mi ne piska, verjetno potem ta čip kontrolira?

Hvala 100X, Blaž



20210111_100328.jpg
 Opis:
 Velikost datoteke:  3.37 MB
 Pogledana:  10 krat

20210111_100328.jpg



20210111_100429.jpg
 Opis:
 Velikost datoteke:  3.39 MB
 Pogledana:  11 krat

20210111_100429.jpg


Nazaj na vrh
Odsoten Poglej uporabnikov profil Pošlji zasebno sporočilo
robert
Član
Član



Pridružen-a: Sob 29 Maj 2004 21:48
Prispevkov: 1728
Aktiv.: 9.43
Kraj: Tolmin

PrispevekObjavljeno: Pon Jan 11, 2021 12:04 pm    Naslov sporočila:   Odgovori s citatom

malci je napisal/a:

Ampak na tej plošči jaz takega vezja ne vidim.


L6219DSA je stepper driver.

Tukaj bi jaz najprej preveril napajalnik - adapter (rak rana vseh naprav)
Naslednje je senzor - če ga pokriješ s kartonom dela ampak ali ga pokrije tudi, ko je zmontiran na svojemu mestu ?
Motor in vodila - teče vse lepo in je namazano ?

_________________
LP Robert
Nazaj na vrh
Odsoten Poglej uporabnikov profil Pošlji zasebno sporočilo
ogblaz
Član
Član



Pridružen-a: Pet 04 Mar 2016 12:08
Prispevkov: 66
Aktiv.: 1.11
Kraj: Domžale

PrispevekObjavljeno: Pon Jan 11, 2021 12:47 pm    Naslov sporočila:   Odgovori s citatom

Tudi z laboratorijskim usmernikom nastavljenim na 15V dela isto, poraba je okrog 0.3A ko motor dela. Brez skoraj na nuli.
Pokrije ga tudi v napravi, vendar, ko priklopim napajanje ga zapelje skrajno naprej se ustavi in tam ostane. Če napajanje prekinem in spet vklopim pa motorček v isti poziciji le trzne. In moram ročno ga spravit na začetek.
Vodila lepo tečejo brez upora.
Bom elektrolite pobral iz vezja in jih premeril!

Hvala!
Nazaj na vrh
Odsoten Poglej uporabnikov profil Pošlji zasebno sporočilo
robert
Član
Član



Pridružen-a: Sob 29 Maj 2004 21:48
Prispevkov: 1728
Aktiv.: 9.43
Kraj: Tolmin

PrispevekObjavljeno: Pon Jan 11, 2021 1:16 pm    Naslov sporočila:   Odgovori s citatom

Potem samo vezje po moje deluje pravilno - kolikor sem videl na internetu.

Se je kaj spreminjalo v nastavitvah računalnika ?
Komunikacija je OK ?
Ste preizkusili z ponovno instalacijo programa?

_________________
LP Robert
Nazaj na vrh
Odsoten Poglej uporabnikov profil Pošlji zasebno sporočilo
ogblaz
Član
Član



Pridružen-a: Pet 04 Mar 2016 12:08
Prispevkov: 66
Aktiv.: 1.11
Kraj: Domžale

PrispevekObjavljeno: Pon Jan 11, 2021 4:32 pm    Naslov sporočila:   Odgovori s citatom

Glede na video ne deluje pravilno, moral bi naprej se obrnit in iti nazaj.
Se mi zdi da bi to moral naresti ne glede na to ali je kam povezan ali ne.
Preko bluetooth na računalniku ne deluje pravilno, povezava je kaže mi km/h to je vse. Tudi preko telefona ne deluje pravilno, telefon ima in bluetooth in ant+

Trenažer je bil kupljen kot pokvarjen oz, da dela le z original programom(kar imam), zato so programi na sveže nameščeni. Danes dobim še ANT+ USB za PC, bom še tako povezal in preizkusil.

Če je kdo vešč teh vezij oz. diagnostike sem pripravljen zadevo poslati in plačati popravilo za neko sindilkalno ceno oz. donacijo v smislu plato piva Smile
Poslal bi le vezje ter motor to kar sem slikal, ker cel trenažer ima 15KG Smile

Hvala!!!!
Nazaj na vrh
Odsoten Poglej uporabnikov profil Pošlji zasebno sporočilo
ogblaz
Član
Član



Pridružen-a: Pet 04 Mar 2016 12:08
Prispevkov: 66
Aktiv.: 1.11
Kraj: Domžale

PrispevekObjavljeno: Tor Jan 12, 2021 11:06 am    Naslov sporočila:   Odgovori s citatom

Dobil sem ANT+ usb adapter in sem uspel posodobit samo plato, je še vedno pokvarjena ampak posodobljena deluje na vse programe.

Pri telovadbi odstranjevanja senzorja sedaj ta ne dela več, ne dela ir led dioda. Ne vem ali jo je uničilo da sem jo priklopil na 5V brez kakšnega upora vmes, na vezju je še vedno 5V kot prej.
Senzor je OPB460N11 ir led v njemu pa dodajam v priponki.

Ker sedaj trenažer dela na vseh napravah je eventuelno kar nekaj vreden in bi dal to nekomu popravit! Ker sam ne bom znal.
Bom dal še v oglase.

Hvala vsem!



20210112_094923.jpg
 Opis:
 Velikost datoteke:  3.03 MB
 Pogledana:  7 krat

20210112_094923.jpg


Nazaj na vrh
Odsoten Poglej uporabnikov profil Pošlji zasebno sporočilo
mucek
Član
Član



Pridružen-a: Tor 01 Avg 2006 10:47
Prispevkov: 4703
Aktiv.: 26.70
Kraj: Ljubljana

PrispevekObjavljeno: Tor Jan 12, 2021 4:24 pm    Naslov sporočila:   Odgovori s citatom

Z direktnim priklopom IR LED diode na 5V si jo najverjetneje skuril (ali dela, vidiš preko kamere od telefona), saj ima napetost nekje 1,8 V in je brez upora na 5 V potegnila daleč preveč toka.
_________________
...lahko pa se tudi motim ...
Nazaj na vrh
Odsoten Poglej uporabnikov profil Pošlji zasebno sporočilo
Pokaži sporočila:   
Objavi novo temo   Odgovori na to temo   Printer-friendly version    www.elektronik.si Seznam forumov -> Elektronika Časovni pas GMT + 2 uri, srednjeevropski - poletni čas
Stran 1 od 1

 
Pojdi na:  
Ne, ne moreš dodajati novih tem v tem forumu
Ne, ne moreš odgovarjati na teme v tem forumu
Ne, ne moreš urejati svojih prispevkov v tem forumu
Ne, ne moreš brisati svojih prispevkov v tem forumu
Ne ne moreš glasovati v anketi v tem forumu
Ne, ne moreš pripeti datotek v tem forumu
Ne, ne moreš povleči datotek v tem forumu

Uptime: 38 dni


Powered by phpBB © 2001, 2005 phpBB Group